bootstrap-validate

v2.2.0

A simple Form Validation Utility for Bootstrap 3 and Bootstrap 4 not depending on jQuery.

Download v1 for Bootstrap 3Download v2 (latest) for Bootstrap 4Star on GitHub

Installation

You can install bootstrap-validate with your favourite package manager and CDN.

Via Package Managers

As stated above you can easily install bootstrap-validate using your favourite package manager. However we do recommend installing with yarn.

yarn

yarn add bootstrap-validate

npm

npm i bootstrap-validate

Via CDN

RawGit makes including bootstrap-validate in your project super easy, providing a CDN allowing you to use a specific version of bootstrap-validate.

For the current version, you can just include

<script src="https://cdn.rawgit.com/PascaleBeier/bootstrap-validate/v2.2.0/dist/bootstrap-validate.js"></script>

Download

You can grab the full Source Code including build files and documentation from our Download Archive..

Usage with Webpack etc.

bootstrap-validate can be used in ES6+ Environments as well. However, importing the library has a small quirk.

You will need to

import * as bootstrapValidate from 'bootstrap-validate';
window.bootstrapValidate = bootstrapValidate;

to export the bootstrapValidate function to your resulting bundle.

Usage →